La mudita & Windows 8.1

laMuditaHace un tiempo que tengo una máquina nueva dando vueltas pero que por una cosa u otra no me decidía a pasarla a “producción”.

La máquina en si es una Acer Aspire M5-481T, pero le puse LaMudita porque el sistema de sonido no le funciona (recientemente descubrí que sí le funciona el sonido por HDMI, así que tan mal no está la cosa). Viene con un I3 y 4Gb de RAM, los cuales en poco tiempo se convirtieron en 6Gb que es lo máximo que admite.

El principal problema de la máquina es su sistema operativo, el cual sobrevivió a las primeras 48hrs de estar conmigo gracias a su característica uEFI. Básicamente me complicó tanto bootearla desde otro sistema operativo que no fuera Windows, que me dió tiempo a encontrarle utilidad a tenerlo instalado (punto para la gente de marketing de MS).

Dado que estoy teniendo problemas con los programas desktop viejos en Windows 8.1 (siempre hay algo que no les funciona), el tener una máquina para desarrollar con esto me gustó bastante. Para el día a día, podría tener Ubuntu en una máquina virtual y tendría lo mejor de los dos mundos en un equipo extremadamente portatil (mi otra maquina tiene 17″).

Pero a mi falta de práctica en el mundo Windows, se sumó una intefaz de usuario totalmente cambiada (algo parecido a lo que pasó con Ubuntu y Unity). Bastante perdido, los primeros días me la pasé aprendiendo atajos de teclado y personalizando la intefaz (el nuevo menú de programas es al día de hoy que sigue sin gustarme).

El problema empezó cuando intenté montar una infraestructura de desarrollo usando vagrant+fabric+virtualbox2. La instalación en Windows da para un post aparte, que en algún momento publicaré. Mi primer intento fue el de instalar todo esto en una máquina virtual con ubuntu a fin de mantenerme trabajando igual que antes del cambio de máquina, pero francamente no pude hacer funcionar la conexión ssh con el servidor creado por vagrant. Tras navegar un poco, parece que es un error común con los usuarios Windows, así que pasé al plan B. Instalar todo en Windows.

La instalación en Windows tuvo sus bemoles, pero finalmente quedó andando. Los servidores se instalaron y parecieron funcionar… hasta que llegué al servidor que tiene Nginxs. Hasta este momento no encontré la forma de evitar un error de archivo inexistente que me aparece cada vez que quiero levantar el servicio. La instalación es correcta y la VM funciona perfectamente en MAC y Linux, pero sobre Windows hay problema. Tras ver en Google que el problema es bastante común con Windows, voy a tener que ver cómo solucionarlo de alguna manera poco ortodoxa (o montando ese servidor en otra máquina o pasando todo el desarrollo a otro equipo).

En resumen, llevo aproximadamente quince días siendo usuario de Windows, y sigo sumando. La experiencia me demostró que para el usuario promedio Windows 8.1 no es tan malo como lo pintan, pero que para el desarrollador  “promedio” es excesivamente controlador (ni a la BIOS se puede acceder sin pasar por el SO), generando problemas sin sentido en las aplicaciones. Si bien todavía se mantiene firme como SO base, no descarto la posibilidad de tenerlo virtualizado y volver a linux como sistema base, pero para eso falta un tiempo, ya que los dolores de cabeza que me está dando hoy día son los que quiero tener frescos para la actualización de los viejos programas a Windows 8.1

 

Leave a Reply

Your email address will not be published. Required fields are marked *